Installing Vista in VMware on Ubuntu

After several failures and a lot of web browsing, I finally succeeded in installing Windows Vista Business in VMware Server running on Ubuntu 6.10.
At first, I just created a new VMware virtual machine with default settings for guest OS Windows Vista (experimental). Booted it from Vista DVD, answered a couple of questions, entered the product key, started the installation and got as far as “Expanding files (0%)”. On the next morning, the installer was still expanding files at 0% (the process had not crashed, it just failed to do anything useful).

Then, I tried to play with the virtual machine settings. Googling around led me to a configuration with 512 MB RAM, 20 GB IDE HDD, NAT networking, and 1 CPU. Booted from Vista DVD, and ended up exactly where I did before.

Finally, I resorted to a workaround provided in VMware’s Guest Operating System Installation Guide (with regard to Vista beta; I was using the officially released version, though), installed Windows XP Pro into a clean virtual machine, and then upgraded that to Windows Vista without any further major problems.

However, I had to conclude that Vista’s installer is designed by morons — just as those of any previous Windows versions. While all the Linux installers I’ve come across recently ask all necessary questions first, and then allow you to safely go to have a cup of coffee, a lunch, or even sleep, the “geniuses” at Redmond have put a question about whether to allow automatic updates or not somewhere halfway down the installation process. Smart, eh?

0 Responses to “Installing Vista in VMware on Ubuntu”


Comments are currently closed.